Troubleshooting | Screen Freezing Issue with PTZ/NC Camera

Learn how to troubleshoot a frozen screen issue with a PTZ/NC camera.

Updated at July 7th, 2023

Problem

The camera screen freezes instantly or in a few seconds when an end device is connected and streaming the camera over a USB bridge.

Other symptoms include:

  • Constant USB disconnection occurs on the Q-SYS Designer Software USB Bridge Status page while streaming the camera screen.
  • The camera screen turns to solid green and freezes
  • Presence of many video_engine sequence errors in the core Q-SYS Log file

Causes

The cause of this issue is likely due to the presence of a 10 Mbps or 100 Mbps negotiated connection in the path between the camera and the end device receiving the camera stream.


Solution | Workaround

  1.  Locate the link in between the devices where the speed is negotiated to 10 Mbps or 100 Mbps. This can be done by accessing the Core/Peripheral Manager or the switch configuration page. 

    Core manager

    1.    Navigate to Network | Basic
    2.    Check the Link Speed of a connection

     
     

    Peripheral Manager

    1.    Navigate to Network Settings
    2.    Check the Link Speed of a connection

     
     

    Netgear Switch AV UI (M4250)

    1.    Login to the AV UI
    2.    Navigate to Configure | Overview
    3.    Hover the mouse over each switchport to check the link speed negotiation

    Refer to their switch configuration guide.

     
     
     
  2.  Confirm that the link speed is not statically set to 10 Mbps or 100 Mbps.
    1. If the link is negotiating to 10 Mbps or 100 Mbps although it is capable of a 1000 Mbps link, replace the cable and confirm that the link speed is negotiating to 1000 Mbps.